Skip to Content

آرشیو

نرم افزار GNS3

نرم افزار GNS3

کمتر از یک هفته قبل کمپانی سازنده ی نرم افزار GNS3 نسخه ی برنامه خود را به  GNS3 1.2.1 ارتقا داد و در حال حاظر  GNS3 1.2.1 آخرین آپدیت این شبیه ساز فوق العاده است

GNS3 چیست ؟

نرم افزار GNS3

نرم افزار GNS3

GNS3 یکی از بهترین نرم افزارهای شبیه سازی شبکه های سیسکو و جونیپر به صورت واقعی است

این نرم افزار به عنوان یک emulator قوی شناخته می شود و دقیقا شرایط واقعی را تقلید میکند برخی نرم افزار پکت تریسر که تنها یک شبیه سازی مصنوعی است و به عنوان SIMULATOR شناخته می شود

طریقه ی کار با نرم افزار GNS3 به این صورت است که شما برای کار کردن سیستم های داخل آن می بایست IOS آنها را داشته باشید به عنوان مثال با در اختیار داشتن IOS روتر 7200 و ایمپورت کردن آن به داخل برنامه شما قادر به استفاده از این مدل روتر هستید و البته به خاطر آنکه روتر به صورت واقعی بر روی سیستم شما بارگزاری می شود از منابع رم و سی پی یو شما استفاده می شود

نرم افزار GNS3

GNS3 قابلیت اتصال به کامپیوتر شما و حتی سیستم های مجازی سازی مثل ماشین مجازی اوراکل را داراست با استفاده از این نرم افزار کلیه سناریوهای شبکه قابل اجراست حتی سناریوهایی همچون NAT که بر اساس اینترنت کار می کنند

به غیر از دارا بودن IOS برای کار با GNS3 احتیاج به نرم افزار دیگری به نام PUTTY دارید که با استفاده از آن به دستگاه های مختلف اتصال کنسول زده آنها را کانفیگ و مدیریت کنید

 

نسخه ویندوز این نرم افزار رو از اینجا دریافت کنید.  GNS3-0.7.4-win32-all-in-one

 

 

 

ادامه مطلب

معرفی Cisco IOS

معرفی Cisco IOS

معرفی Cisco IOS

معرفی Cisco IOS

 

ایــن فــصل شــامل معرفــی Device هــای سيــسکو چــون روتــر و ســوئيچ و سيــستم عامــل مخــتص بــه سيــسکو IOS Cisco و نحوه ارتباط و پيکربندی اوليه هر کدام از آنها می باشد . در انتهای ایـن فـصل مـی آموزیـد کـه چگونـه بـا Device هایی چون router و switch ارتباط برقرار کرده و آنها را جهت استفاده در یک شبکه پيکربندی کنيد .

(IOS (System operating Internetwork هسته مرکزی روتر و بيـشتر سـوئيچ هـای سيـسکو چـون سـوئيچ 2950 مـی باشد . در واقع سيستم عامل روترهای سيسکو همانند دیگر سيستم عامل ها وظيفه ذخيره و بازیابی فایـل ، مـدیریت حافظه و مدیریت سرویس های مختلف را به عهده دارد . این سيستم عامل فاقد محيط گرافيکی بوده و مبتنی بـر خـط فرمان می باشد لذا دارای یک واسط کاربری UI می باشد که به کمـک آن دسترسـی بـه فـرامين و پيکربنـدی تجهيـزات سيسکو امکان پذیر می باشد. IOS در دو mode پيکربندی می شود ، mode up set و دیگری CLI . :Set UP Mode هنگامی که روتر و یا بعضی از سوئيچ های سيسکو مثل سوئيچ 2950 را برای بـار نخـست راه انـدازی مـی کنيـد وارد mode up set شده و می توانيد تنظيمات اوليه چون آدرس دهی و تنظيم پسوردها را انجـام دهيـد . درواقـع یـک سـری سوالات به صورت متوالی از شما پرسيده می شود و می توانيد با پاسخ دادن به هـر کـدام از آنهـا تنظيمـات اوليـه را در همين ابتدای کار انجام دهيد . البته این تنظيمات کامل نخواهند بود و برای تنظيم بيشتر می بایست به Mode دیگری مراجعه کرد . همچنين می توانيد به جای پاسخ دادن به این سوالات مستقيما وارد Mode Setup شوید و در هنگام نياز این تنظيمات را انجام دهيد . :(Common Line Interface) CLI (CLI (interface line-Command IOS Cisco جایگـاهی اسـت کـه مـی توانيـد تنظيمـات بيـشتری را روی روتـر و سـوئيچ انجام دهيد. CLI یک محيط Base text می باشد به طوری که user در این محيط فرامين مورد نظرش را type می کند. برای دسترسی به این محيط سه روش وجود دارد که در ادامه با این سه روش آشنا می شوید.

 

 

 

ادامه مطلب

روتینگ و سوئیچینگ

روتینگ و سوئیچینگ

گروه فنی و مهندسی وی سنتر مفتخر است که توانایی ارائه خدمات Routing and Switching را در مراحل طراحی ، پیاده سازی ، نگهداری و به روز رسانی مطابق با استاندارد های بین المللی دارا می باشد.

روتینگ و سوئیچینگ

روتینگ و سوئیچینگ

•  طراحی شبکه بر مبنای استاندارد سه لایه Core,Distribute,Access کمپانی Cisco
•  نگهداری و به روز رسانی سخت افزاری و نرم افزاری تجهیزات های مرتبط با Routing and Switching
•  ارائه راهکار های سوئیچینگ لایه 2، در شبکه های LAN , WAN
•  ارائه راهکار های سوئیچینگ لایه 2، در شبکه های WAN (ATM, Frame Relay,DSL,STM1,…
•  طراحی ، راه اندازی و پشتیبانی شبکه Switching  کشوری (MPLS)
•  ارائه راهکارهای Routing مبتنی بر الگوریتم های مسیر یابی Static وEGP,IGP) Dynamic)
•  ارائه راهکارهای Routing and Switching مبتنی بر اولویت نوع اطلاعات (Qos)
•  ارائه راهکارهای load balancing مبتنی بر اولویتهای Active-Active

لازم به ذکر است که گروه فنی و مهندسی وی سنتر کلیه خدمات فوق را با استفاده از محصولات کمپانی های معتبری مانند HP,Foundry,Cisco و Mikrotik ارائه می نماید.

ادامه مطلب

مفهوم مکانیزم Split Horizon

Split Horizon یکی از روش ها و یا قوانین کنترل ( Loop ) در شبکه های Dynamic Routed ، که ترافیک آنها توسط روتینگ پروتکل روت میشود است ، در واقع به کمک Split Horizon ، میتوان از بروز دور و تسلسل (Loop) که یکی از مهمترین آفت های روتینگ پروتکل ها ، در شبکه است ، جلوگیری کرد .

Split Horizon با اتکا به اصلی  بسیار ساده و کارا ، از بروز چرخه یا loop در شبکه جلوگیری میکند ، بدین ترتیب که :

”  هیچ گاه ، Network هایی که در یک update از یک اینترفیس (interface) دریافت شده ، از همان interface دوباره (تبلیغ) Advertise نمیشود “

این بدین معنیست که بر طبق قانون Split Horizon ، هر گاه یک روتر توسط یک اینترفیس خود ، مثلا Fast0/0 با روتری همسایه باشد ، و در یک Update ، نتورکی ، مثلا 192.168.0.0/24 را از آن روتر دریافت کند ، هیچ گاه ، دوباره نتورک 192.168.0.0/24 را نه به روتر مبدا ، و نه به هیچ روتر دیگری که بر روی همان اینترفیس با آن همسایه است ، تبلیغ نخواهد کرد .

split horizon چیست

این قانون بسیار کاراست و باعث جلوگیری از به وجود آمدن بسیاری از Loop ها در شبکه های حتی بزرگ نیز میشود ، فقط در بعضی موارد خاص اقدام به غیر فعال کردن این قابلیت بر روی اینترفیس ها میکنند ، برای مثال یک شبکه RAS یاDMVPN که که قبلا به توضیح آن پرداختیم ، در نظر بگیرید ، در صورت فعال بودن Split Horizon ، هیچ روتینگ پروتکلی ، قادر به کارکرد نخواهد بود ، به لحاظ اینکه ، تمامی روتر ها بر روی اینترفس tunnel خود ، با روتر هاب ، همسایه هستند ، لذا ، بنا بر قانون Split Horizon ، روتر هاب ، از ارسال آپدیت نتورک ها خود داری میکند ، زیرا از همان اینترفیس آنها را دریافت کرده است ، بنابراین میبایست در برخی موارد و نیز در شبکه های کنترل شده LAN و Frame Relay به شکل Point to Multipoint ، اقدام به غیرفعال نمودن Split Horizon بر روی روتر سیسکو ، جهت کارکرد صحیح روتینگ پروتکل ها ، نمود ، البته شایان ذکر است که Split Horizon به صورت default برای RIP بر روی Frame Relay ، غیر فعال است .

جهت غیر فعال کردن Split Horizon بر روی روتر سیسکو و یک اینترفیس ، در یک شبکه EIGRP از این دستور استفاده نمائید :

Aka-Core(config-subif)#no ip split-horizon eigrp 1

split horizon

از آنجایی که کشور آمریکا ، مهد تکنولوژی و نظم و امنیت و صدالبته آزادی omg! و حقوق بشرو طرفدار سینه چاک دسترسی عموم به جریان آزاد اطلاعات است ، این قانون با نام مستعار Smith-Mundt’s در سال 1948 ، حتی قبل از ظهور شبکه :)) در آمریکا تصویب و براساس آن ، دریافت هرگونه اخبار ، شانتاژ ، تهاجم فرهنگی ، فضاسازی ، بمب خبری ، شایعه و … که توسط آمریکا ، برای کشور های مخالف آزادی و مدافع فیلترینگ مثل ایران :دی ، ارسال میشود ، توسط شهروندان شخیص و انسان و گوسپند آمریکایی ، ممنوع است ، لذا تمامی خبرگذاری ها ملزم به جلوگیری از درز اخبار از منابعی مثل voa و امثالهم به رسانه های عمومی و داخلی آمریکا هستند ! و اینگونه شهروندان در رفاه و آرامش و صد البته آزادی ، به خوبی و خوشی در مراتع سرسبز ، زندگی ، نه ،  میچرند !!

بین کارشناسان و فعالان آمریکایی ، این قانون به دیوار آتش Firewall خودمان ، مثل ASA سیسکو :دی ، معروف است :)) !

ادامه مطلب

فعال کردن امکان روتینگ توسط سوئیچ لایه سه سیسکو

روتینگ امکان جالب و هیجان انگیزی برای یک سوئیج است ، به تعبیری ، روتینگ حدفاصل بین سوئیچ و روتر را کمتر میکند ، در واقع محصولات جدید سیسکو را نه میتوان روتر نامید نه سوئیچ ، چون مثلا سری 6500 امکانات لایه یک تا هفت را در حد عالی به شما ارائه میکند که این باعث میشود تصویر ذهنی کاربران نسبت به این محصولات عوض شود …

روتینگ قابلیتی است که ما منحصرا آن را در اختیار روتر های در محصولات سیسکو میئنداشتیم ، اما با ارائه سوئیچ کاتالیست سیسکو 3550 ، و امکانات فوق العاده لایه 3 آن ، نظر ها عوض شد . در نگاه یک کارشناس شبکه ، سوئیچ لایه سه سیسکو ، ابزاری همه فن حریف است که پاسخگوی گستره وسیعی از نیازهای شبکه است ، محدودیت تعداد پورت روتر را نداشته و همچنین از فناوری ASIC برای پردازش استفاده میکند که این باعث load کمتر و سرعت بیشتر است البته نباید این نکته را فراموش کرد که سوئیچ ها اساسا سوئیچ هستند . برای این کار بهینه سازی شده اند ، برای مثال RAM سوئیچ ها قابل ارتقاء نبوده و از ماژول های WIC و NM و همچنین ارتباطات WAN و تکنولوژی های مربوط به آن پشتیبانی نمیکنند در واقع سوئیچ ها با VLAN ها کاردارند و این امکانات روتینگی لایه سه ، این مزیت را به سوئیچ های سیسکو میبخشد که بتوانند ترافیک این VLAN ها را هم Route کنند .

روتینگ قابلیت بسیار مهمی بود که سیسکو از سری 3550 به سوئیچ های میان رده خود اضافه نمود که پس از آن 3560 با بهبود های فراوان و سپس سوئیچ سیسکو 3750 ، پادشاه سوئیچ های سیسکو با قابلیت های فراوان و قدرت بالا ، حلال مشکلات شبکه ها و مطلوب متخصصان شبکه گردید ، بدین ترتیب که در اکثر پیاده سازی ها ، حضور سوئیچ سیسکو 3750 به عنوان جزئی بی بدیل از شبکه مشاهده میشود .

البته محدودیت های و تفاوت های زیادی بین یک روتر و یک سوئیچ لایه سه وجود دارد که نمی توان از آن چشم پوشی کرد و همیشه نیاز به یک روتر صرف در شبکه های حتی کوچک هم حس میشود برای مثال امکانات NAT کردن در سوئیچ های لایه سه وجود ندارد ، ولی با تمام این احوال ، امکانات dynamic routing و پشتیبانی از پروتکل های روتینگی مهمی مثل EIGRP – OSPF – BGP و همچنین استاتیک روتینگ ، Policy Based Routing امکانات ACL حرفه ای و QOS و خیل کثیری از امکانات روتر ها در سوئیچ های لایه 3 وجود داشته که با توجه به تعدد پورت ها ، استفاده از آنها در بسیاری از ماموریت ها ، راه گشا خواهد بود .

برای فعال کردن امکانات روتینگ در سوئیچ لایه سه ، مثل سوئیچ سیسکو 3750 ، و تبدیل آن به یک روتر ، کار چندانی لازم نیست که انجام دهید ، کافیست ابتدا با دستور IP Routing ، امکانات روتینگ را فعال کرده و پس از آن میتوانید به هر پورت IP اختصاص دهید و یا پورت ها را در لایه 2 قرار داده و به vlan ها IP دهید ، از دیگر قابلیت ها امکان فعال سازیDHCP برای اختصاص IP به کلاینت ها و همچنین فعال سازی dynamic routing protocol است .

نکته جالب اینکه ، پس از فعال کردن امکانات روتینگ سوئیچ لایه سه سیسکو ، خللی در کارکرد لایه دو آن ایجاد نمیشود ، بلکه میتوانید تنظیمات لایه دو خود را نظیر vlan ها و پورت های trunk و همچنین stp – vtp – etherchannel را نیز داشته باشید .

مثال : فعال کردن امکانات روتینگ :

Aka-3750(config)#ip routing

اختصاص IP به یک پورت خاص

Aka-3750(config)#int gi 1/0/20
Aka-3750(config-if)#no switchport
Aka-3750(config-if)#ip add 217.218.1.1 255.255.255.0

کانفیگ پورت به صورت لایه 2 و اختصاص IP به vlan مربوطه :

Aka-3750(config-if)#switchport
Aka-3750(config-if)#switchport mode access
Aka-3750(config-if)#sw acce vlan 303

Aka-3750(config)#int vlan 303
Aka-3750(config-if)#ip add 217.218.1.1 255.255.255.0

فعال کردن eigrp :

Aka-3750(config)#router eigrp 1
Aka-3750(config-router)#network 217.218.1.0 0.0.0.255
Aka-3750(config-router)#redistribute connected
Aka-3750(config-router)#no auto-summary

نوشتن یک استاتیک روت :

Aka-3750(config)#ip route 8.8.8.8 255.255.255.255 172.16.64.1

نوشتن یک ACL و اختصاص آن :

Aka-3750(config)#ip acce e 110
Aka-3750(config-ext-nacl)#per ip 217.218.1.0 0.0.0.255 any
Aka-3750(config-ext-nacl)#per icmp an any
Aka-3750(config-ext-nacl)#per tcp an an eq 80
Aka-3750(config-ext-nacl)#deny ip any any

Aka-3750(config)#int vlan 301
Aka-3750(config-if)#ip access-group 110 in

اینها مثال هایی بود از گوشه ای از امکانات لایه سه ایه سوئیچ های لایه سه سیسکو ، که با فعال کردن قابلیت روتینگ آن ، دری جدید از امکانات و قابلیت ها به روی شما گشوده خواهد شد .

در کل با تمام کارامدی سوئیچ های لایه سه سیسکو ، نباید ماموریت ذاتی و اصلی این تجهیزات که همانا سوئیچینگ است را از خاطر برد ، این سوئیچ ها با بهبود های نرم افزاری صورت گرفته امکانات روتینگ را نیز برای بهبود عملکرد دارا بوده ، ولی نباید از آنها قابلیت های یک روتر تمام عیار را انتظار داشت همانطور که با اضافه کردن یک ماژول سوئیچ NME-X-23ES-1G به یک روتر ISR نمیتوان قابلیت ها و پرفورمنس کامل یک سوئیچ را از آن انتظار داشت ، چون یک روتر است !! ولی در مواردی مثلا یک pop site و یا در مقاطعی که نیاز به تعدد پورت و همچنین روتینگ باشد ، به جای استفاده از یک سوئیچ در کنار روتر و inter vlan routing ، میتوان از امکانات ویژه یک سوئیچ لایه سه بهره مند گردید .

ادامه مطلب

راه اندازی EtherChannel در سیسکو

از سال های بسیار دور IOS سیکسو دارای قابلیت Etherchannel بود. اگر شما سوئیچی قدیمی و از نوع سیکسو دارید اصلا نگران نباشید زیرا به احتمال بسیار زیاد می توانید این قابلیت را فعال نموده و از آن استفاده نمایید.

اصلا نگران پیاده سازی Etherchannel روی سوئیچ نباشید و با دلی آرام و ضمیری آگاه داستان را ادامه بدهید. منتهی قبل از کانفیگ سوئیچ مطالب زیر را مورد بازبینی قرار دهید تا دچار مشکلات غیرقابل پیش بینی نشوید.

EtherChannel قابلیت کانفیگ تا 8 پورت را به شما می دهد و همه ی این پورت ها باید دارای Type های مشابه باشند مثلا همه ی آنها باید Fast Ethernet و یا Gigabit Ethernet باشند.

همه ی پورت ها باید روی سرعت های مشابه و به صورت Duplex باشند.

مطمئن شوید همه ی پورت ها Enable و دستور Shutdown روی آنها استفاده نشده باشد.

تنظیمات مربوط به Switchport از اولین پورت EtherChannle به روی همه پورت های EtherChannel کپی می شود این در شرایطی است که اینترفیس به یک ChannelGroup اضافه می شود. این action یک کپی می باشد و یک لینک نیست بنابراین اگر تغییری بعد از تنظیمات انجام شود شما باید این تغییر را روی تمام پورت ها اعمال نمایید.تغییراتی که باید به صورت مشابه بر روی تمام اینترفیس ها باقی بماند:

1- Allowed VLAN List

2- STP Path Cost

3- STP Port Priority

3- STP PortFast  Settings

4- Etherchannel Groups

Cisco’s  GigaStack , FlexStack و … هرگز نباید بعنوان یک قسمتی از Etherchannel  تنظیم بشوند به این خاطر که این Stacking پورت ها هر کدام به منظور خاصی فعال شده اند و با قابلیت EtherChannel سازگار نمی باشند.

پورسه معمول جهت کانفیگ کردن اینترفیس برای EtherChannel  بر اساس مراحل زیر می باشد:

1- به محیط CLI سوئیچ وصل شوید و دستورات زیر را وارد نمایید:

Switch1> enable

Switch1# configure terminal

Switch1(config)#interface range fastethernet0/11 -12

Switch1(config-if-range)#switchport mode access

Switch1(config-if-range)switchport access vlan 10

End

EtherChannel Mode:

 

 

 

Mode

Protocol

توضیحات

Auto PAgP

تنظیم این پروتکل روی اینترفیس باعث می شود به پکت های PAgP پاسخ بدهد. اما اینترفیس خودش شروع کننده negotiation خواهد بود.

Desirable PAgP

تنظیم بر روی اینترفیس باعث می شود ارتباط در حالت PAgP فعال شود

ON Etherchannel

در این حالت لینک آپ میشود بدون اینکه پروتکلی negotiate کند. این مد تنها به دیوایسی متصل میشود که دقیقا همین تنظیمات را داشته باشد.

Active LACP

وقتی روی اینترفیس تنظیم می شود کانکشن Negotiate خواهد کرد با دیوایس های دیگری که LACP هستند

Passive LACP

تنظیم کردن اینترفیس جهت پاسخگویی به درخواست سایر سیستم ها جهت Negotiate دیتا LACP

 

دستورات بالا، دستوراتی بودند برای اینکه شما  EtherChannel روی یک سوئیچ پیاده سازی نمایید.  توجه داشته باشید که کلمه “Desirable” به این معنی است که از پروتکل اختصاصی سیسکو استفاده خواهید کرد. این مفهوم حاوی این مطلب می باشد که سوئیچ دیگر این سناریو هم باید یک سوئیچ سیسکویی باشد … بعبارتی end 2 end داستان باید سیسکو باشد.

Switch1> enable

Switch1# configure terminal

Switch1(config)# interface range fasttethernet0/11 -12

Switch1(config-if-range)# switchport mode access

Switch1(config-if-range)# switchport access vlan 10

Switch1(config-if-range)# channel-group 5 mode desirable

Switch1(config-if-range)# end

 

توجه داشته باشید که روی سوئیچ دوم تنظیمات زیر را اعمال می نمایید. همان گونه که مشاهده میکنید تنظیمات مربوط به Channel-group مورد استفاده روی سوئیچ متفاوت است. تفاوت پورت گروپ ها مورد تایید هستند. به خاطر اینکه تنظیمات لوکال هر پورت گروپ منحصر بفرد را شناسایی می نماید. تعداد زیادی از ادمین ها شماره Channel-Groupها را شبیه هم میگزارند به این دلیل که در هر سوئیچی کاملا مشخص باشد که هر پورت گروپی چگونه تنظیم شده است و این باعث میشود از سرگیجه آنها جلوگیری شود. این امر هیچ دلیل دیگری ندارد!

Switch2> enable

Switch2# configure terminal

Switch2(config)# interface range fasttethernet0/1 -2

Switch2(config-if-range)# switchport mode access

Switch2(config-if-range)# switchport access vlan 10

Switch2(config-if-range)# channel-group 2 mode auto

Switch2(config-if-range)# end

 

در تنظیمات بالا، پورت های Pair شده به شما اجازه می دهند که فقط دیتا از VLAN 10 روی EtherChannel جابجا شود. برای عبور دادن ترافیک برای تمام VLAN ها باید تنظیمات مربوط به Trunk را انجام بدهید.

ادامه مطلب

تفاوتهای سوئیچ های سیسکو سری Nexus 7000 و Catalyst 6500

تفاوتهای-سوئیچ-های-سیسکو-سری-Nexus-7000-و-Catalyst-6500

مهندسین شبکه بحث های فراوانی را در رابطه با مقایسه ۶۵۰۰ ,Nexus انجام میدهند ولی جواب سوال از کدام یک استفاده کنم همچنان مبهم است.بستگی به نیازهایتان دارد.هر دو دارای تواناییهای خوبی هستند و انتخاب بستگی به اینکه کاربری شما نیازمند چه Interfaceها و چه خصوصیتهایی است، دارد.

الف) تفاوت های ساختاری

•معماری ارسال بسته Forwarding Architecture

مهمترین تفاوت ، معماری ارسال است. ۶۵۰۰ می تواند از هر دو تکنولوژی ارسال مرکزی که در آن sup تصمیمات ارسال را می گیرد و ارسال توزیع شده که در آن  Line Card ها تصمیمات ارسال را می گیرند استفاده نماید در حالی که Nexus فقط از ارسال توزیع شده استفاده می کند.

• Switch Fabric

در ۶۵۰۰ فابریک سوئیچ در sup ادغام گردیده است در حالی که در Nexus 7000 فابریک سوئیچ در قسمت جداگانه ای از شاسی بدون وابستگی به بقیه کارت ها قرار دارد که در نتیجه آن در ۷۰۰۰ ، sup تنها اعمال کنترلی را بر عهده می گیرد و سیستم عامل را اجرا کرده و کل سیستم را مدیریت می نماید و دیگر امکانات ارسالی بر روی آن قرار ندارد.

• Interface  ها:

یکی از اساسی ترین تفاوت های این دو در interface های مورد پشتیبانی است.هم سری ۶۵۰۰ و هم Nexus 7000 از اینترفیس های ۴۰Gb پشتیبانی می کنند. در حالی که فقط Nexus 7000 از ۱۰۰ Gb پشتیبانی م

ی کند. در کاربردهای قدیمی ۱۰G و ۱G نیز سری ۷۰۰۰ از Line card هایی با تعداد بیشتری پورت پشتیبانی می نماید.

ب) تفاوت های خصوصیات و تکنولوژیها:

با اینکه هر دو سری امکانات سوئیچینگ لایه ۳، پشتیبانی از روتینگ پروتکل ها ، MPLS/VRF و QoS را دارند ولی هر یک تواناییهای منحصر به فرد خود را نیز دارا هستند که در ادامه مورد بررسی قرار می گیرد.

VSS -Virtual Switching System :

مهندسین شبکه همواره در شبکه ها از افزونگی در ارتباطات و سوئیچها به منظور افزایش قابلیت اطمینان استفاده می کنند ولی این مورد باعث ایجاد پیچیدگی هایی در طراحی و کارکرد شبکه می گردد. VSS در ۶۵۰۰ شبکه را با کوچکتر کردن تعداد ادوات شبکه از پیچیدگی و مدیریت مسیرها و سوئیچهای افزونه ( (redundant می کاهد. VSS دو سوئیچ فیزیکی را به یک سوئیچ تبدیل کرده و باعث ساده تر شدن ساختار می شود . VSS دو سوئیچ فیزیکی را به یک سوئیچ تبدیل کرده و باعث ساده تر شدن ساختار Port Channelها می شود. همچنین باعث کاهش تعداد همسایگان در روتینگ لایه ۳ میگردد و از بوجود آمدن Loop های لایه ۲ نیز جلوگیری می کند.مثلاً به صورت فیزیکی در لایه توزیع شبکه معمولاً هر سوئیچ دسترسی (Access) به وسیله دو لینک مجزا به دو سوئیچ توزیع (Distribution) متصل میگردد.به وسیله VSS میتوان Port channel های منطقی از یک سوئیچ دسترسی تعریف نمود و توپولوژی لایه۳و امکانات بالانس ترافیکی (Load Balancing) را به وجود آورد. همچنین به کمک VSS دیگر لازم نیست مهندسان شبکه خود را با Spanning Tree درگیر نمایند.در Nexus این موارد از طریق VPC انجام میپذیرد.

•Virtual Port-Channel- vPC :

کاربرد اصلی این مورد در Nexus 7000 نیز استفاده از امکان Link Aggregation در چند سوئیچ فیزیکی مختلف است ولی آن را به صورت متفاوتی انجام می دهد . تفاوت اصلی در این است که در Control plane ,VSS ها به صورت منطقی واحد در نظر گرفته می شود ولی در vPC اینگونه نیست . بنابراین هر دو سوئیچ می توانند به صورت کاملاً مستقل عمل نمایند و به همین علت نیز Ether Channel های ساخته شده بین چند سوئیچ قابلیت لایه ۳ ندارند و نیاز به استفاده از پرو تکل هایی نظیر HSRP وجود دارد.

•ماژولهای سرویسدهی Service Modules

۶۵۰۰ از ماژول های سرویس دهی پشتیبانی میکند مانند ASA-SM که امکانات فایروال با توان عملیاتی بالا را فراهم می کند و نیز NAM که امکانات گزارشگیری ترافیک و مدیریت را فراهم میسازد در حالی که Nexus 7000 از آنها پشتیبانی نمی نماید.

Virtual Device Context- VDC:

این امکان در Nexus 7000 اجازه می دهد که یک سوئیچ فیزیکی به چندین سوئیچ کاملاً مستقل منطقی تقسیم شود و Control Plane نیز به چند قسمت تقسیم شود و هر سوئیچ منطقی را مستقل می نماید تا مطمئن شود که هیچگونه وابستگی به یکدیگر ندارند. این قابلیت به منظور استقلال نگهداری سیستمها استفاده میشود به طور مثال بخش امنیت فقط به DMZ VDC دسترسی داشته باشد. VPC ها هیچگونه ارتباطی با هم ندارندمگر اینکه ارتباط فیزیکی پورتهای آنها برقرار گردد.

•WAN Interfaces:

۶۵۰۰ امکان استفاده از Interface های WAN وسیعی از E1، T1 تا OC ، STM را دارا میباشد.

•Fabric Extender:

Nexus 7000 دارای پشتیبانی از Fabric Extender های سری Nexus 2200 است که امکان به وجود آمدن شاسی های مجازی برای کاربردهای بزرگ در دیتا سنتر را به وجود می آورد همچنین به کمک تکنولوژی FCoE امکان یکی کردن بستر SAN و شبکه اترنت به وجود می آید و دیگر نیازی به استفاده از دو زیر ساخت مستقل برای SAN و شبکه وجود ندارد.

ادامه مطلب

دوره آموزشی CCNA

نام دوره : CCNA: Certified Cisco Network Associate -ICND1+ICND2

 تعداد ساعت : 60
شهريه : 8,000,000 ریال
ثبت نام دوره آموزشی امنیت CEH
سیلابس دوره

Module 1:Operation of IP Data Networks

  • Operation of IP Data Networks
  • Recognize the purpose and functions of various network devices such as Routers, Switches, Bridges and Hubs.
  • Select the components required to meet a given network specification.
  • Identify common applications and their impact on the network
  • Describe the purpose and basic operation of the protocols in the OSI and TCP/IP models.
  • Predict the data flow between two hosts across a network.
  • Identify the appropriate media, cables, ports, and connectors to connect Cisco network devices to other network devices and hosts in a LAN

Module 2:LAN Switching Technologies

  • Determine the technology and media access control method for Ethernet networks
  • Identify basic switching concepts and the operation of Cisco switches.
    • Collision Domains
    • Broadcast Domains
    • Types of switching
    • CAM Table
  • Configure and verify initial switch configuration including remote access management.
    • Cisco IOS commands to perform basic switch setup
  • Verify network status and switch operation using basic utilities such as ping, telnet and ssh.
  • Identify enhanced switching technologies
    • RSTP
    • PVSTP
    • Ethercnannels
  • Describe how VLANs create logically separate networks and the need for routing between them.
    • Explain network segmentation and basic traffic management concepts
  • Configure and verify VLANs
  • Configure and verify trunking on Cisco switches
    • DTP
    • Auto negotiation
  • Configure and verify PVSTP operation
    • describe root bridge election
    • spanning tree mode

Module 3:IP addressing (IPv4 / IPv6)

  • Describe the operation and necessity of using private and public IP addresses for IPv4 addressing
  • Identify the appropriate IPv6 addressing scheme to satisfy addressing requirements in a LAN/WAN environment.
  • Identify the appropriate IPv4 addressing scheme using VLSM and summarization to satisfy addressing requirements in a LAN/WAN environment.
  • Describe the technological requirements for running IPv6 in conjunction with IPv4 such as dual stack
  • Describe IPv6 addresses
    • Global unicast
    • Multicast
    • Link local
    • Unique local
    • eui 64
    • autoconfiguration

Module 4:IP Routing Technologies

  • Describe basic routing concepts
    • CEF
    • Packet forwarding
    • Router lookup process
  • Describe the boot process of Cisco IOS routers
    • POST
    • Router bootup process
  • Configure and verify utilizing the CLI to set basic Router configuration
    • Cisco IOS commands to perform basic router setup
  • Configure and verify operation status of a device interface, both serial and ethernet
  • Verify router configuration and network connectivity
    • Cisco IOS commands to review basic router information and network connectivity
  • Configure and verify routing configuration for a static or default route given specific routing requirements
  • Manage Cisco IOS Files
    • Boot preferences
    • Cisco IOS image(s)
    • Licensing
      • Show license
      • Change license
  • Differentiate methods of routing and routing protocols
    • Static vs. Dynamic
    • Link state vs. Distance Vector
    • Administrative distance
    • split horizon
    • metric
    • next hop
    • ip routing table
    • Passive Interfaces
  • Configure and verify OSPF (single area)
    • Benefit of single area
    • neighbor adjacencies
    • OSPF states
    • Discuss Multi area
    • Configure OSPF v2
    • Configure OSPF v3
    • Router ID
    • Passive interface
    • LSA types
  • Configure and verify EIGRP (single AS)
    • Feasible Distance / Feasible Successors /Administrative distance
    • Feasibility condition
    • Metric composition
    • Router ID
    • Auto summary
    • Path selection
    • Load balancing
      • Equal
      • Unequal
    • Passive interface
  • Configure and verify interVLAN routing (Router on a stick)
    • sub interfaces
    • upstream routing
    • encapsulation
  • Configure SVI interfaces

Module 5:IP Services

  • Configure and verify DHCP (IOS Router)
    • configuring router interfaces to use DHCP
    • DHCP options
    • excluded addresses
    • lease time
  • Describe the types, features, and applications of ACLs
    • Standard
      • Sequence numbers
      • Editing
    • Extended
    • Named
    • Numbered
    • Log option
  • Configure and verify ACLs in a network environment
    • Named
    • Numbered
    • Log option
  • Identify the basic operation of NAT
    • Purpose
    • Pool
    • Static
    • 1 to 1
    • Overloading
    • Source addressing
    • One way NAT
  • Configure and verify NAT for given network requirements
  • Configure and verify NTP as a client
  • Recognize High availability (FHRP)
    • VRRP
    • HSRP
    • GLBP
  • Configure and verify Syslog
    • Utilize Syslog Output
  • Describe SNMP v2 & v3

Module 6:Network Device Security

  • Configure and verify network device security features such as
    • Device password security
    • Enable secret vs enable
    • Transport
    • Disable telnet
    • SSH
    • VTYs
    • Physical security
    • Service password
    • Describe external authentication methods
  • Configure and verify Switch Port Security features such as
    • Sticky MAC
    • MAC address limitation
    • Static / dynamic
    • Violation modes
      • Err disable
      • Shutdown
    • Protect restrict
    • Shutdown unused ports
    • Err disable recovery
    • Assign unused ports to an unused VLAN
    • Setting native VLAN to other than VLAN 1
  • Configure and verify ACLs to filter network traffic
  • Configure and verify an ACLs to limit telnet and SSH access to the router

Module 7:Troubleshooting

  • Identify and correct common network problems
  • Utilize netflow data
  • Troubleshoot and correct common problems associated with IP addressing and host configurations.
  • Troubleshootand Resolve VLAN problems
    • identify that VLANs are configured
    • port membership correct
    • IP address configured
  • Troubleshoot and Resolve trunking problems on Cisco switches
    • correct trunk states
    • correct encapsulation configured
    • correct vlans allowed
  • Troubleshoot and Resolve Spanning Tree operation issues
    • root switch
    • priority
    • mode is correct
    • port states
  • Troubleshoot and Resolve routing issues
    • routing is enabled
    • routing table is correct
    • correct path selection
  • Troubleshoot and Resolve OSPF problems
    • neighbor adjancies
    • Hello and Dead timers
    • OSPF area
    • Interface MTU
    • Network types
    • Neighbor states
    • OSPF topology database
  • Troubleshoot and Resolve EIGRP problems
    • neighbor adjancies
    • AS number
    • Load balancing
    • Split horizon
  • Troubleshoot and Resolve interVLAN routing problems
    • Connectivity
    • Encapsulation
    • Subnet
    • Native VLAN
    • Port mode trunk status
  • Troubleshoot and Resolve ACL issues
    • Statistics
    • Permitted networks
    • Direction
      • Interface
  • Troubleshoot and Resolve WAN implementation issues
    • Serial interfaces
    • PPP
    • Frame relay
  • Troubleshoot and Resolve Layer 1 problems
    • Framing
    • CRC
    • Runts
    • Giants
    • Dropped packets
    • Late collision
    • Input / Output errors
  • Monitor NetFlow statistics
  • Troubleshoot etherchannel problems

Module 8:WAN Technologies

  • Identify different WAN Technologies
    • Metro Ethernet
    • VSAT
    • Cellular 3G / 4G
    • MPLS
    • T1 / E1
    • ISDN
    • DSL
    • Frame relay
    • Cable
    • VPN
  • Configure and verify a basic WAN serial connection
  • Configure and verify a PPP connection between Cisco routers
  • Configure and verify Frame Relay on Cisco routers
  • Implement and troubleshoot PPPoE
ادامه مطلب

آموزش راه اندازی DHCP سرور بر روی روتر و سوییچ سیسکو

آموزش-راه-اندازی-DHCP-سرور-بر-روی-روتر-و-سوییچ-سیسکو

اگر به دنبال این هستید که برای استفاده کلاینت های شبکه خود از سرویس DHCP استفاده کنید ، چندین راهکار وجود دارد . معمولا در اکثر شبکه ها از یک سرور ویندوزی یا لینوکسی به عنوان DHCP سرور استفاده می شود و یا از همان مودم DSL یا روتر اینترنت به عنوان DHCP سرور استفاده می شود . اکثر مدیران شبکه حتی فکر این را نمی کنند که از تجهیزات سیسکو مانند روتر و سویچ سیسکو می توانند به عنوان DHCP سرور استفاده کنند . البته فراموش نکنید که این قابلیت با نسخه های جدید از IOS های سیسکو ارائه شده است و با سری محصولات Catalyst 3550 و 3750 ارائه شده است . اولین کار این است که در نظر بگیریم که آیا این راهکار به درد سازمان ما می خورد یا خیر . استفاده از روتر و سویچ به عنوان DHCP سرور مزایا و معایت خاص خود را دارد . مثلا فرض رو بر این بگیرید که شبکه ای دارید که بصورت ترکیبی شامل چندین شبکه است و شما میخواهید توسط یک روتر به کلیه آنها آدرس دهی کنید .

یکی از مزایای استفاده از روتر و سویچ به عنوان DHCP سرور این است که نیاز به سخت افزار اضافی ندارد و هزینه اضافی برای شما در بر نخواهد داشت ، بر خلاف اینکه در صورت استفاده از یک سرور ویندوزی حتما به سخت افزار اضافه نیاز خواهید داشت و این برای سازمان شما یعنی هزینه اضافی .از معایب این راهکار این است که برخی از مدیران شبکه برای مانتیورینگ و نگهداری روتر دچار مشکل هستند و با رابط کاربری خط فرمانی آن دچار مشکل هستند و این خود یکی از مهمترین دلایل استفاده نکردن از این راهکار محسوب می شود.خوب این طبیعی است که مدیریت و نگهداری یک محیط گرافیکی مانند ویندوز سرور بسیار راحتتر و آسانتر از دستورات IOS سیسکو است . اما در کل این راهکار بسیار برای مدیران شبکه کارآمد و مفید است . خوب بریم سراغ انجام تنظیمات ، ما تنظیمات رو بر حسب یک IOS جدید انجام میدیم که تنظیمات بصورت پیشفرض قرار داشته باشه ، خوب یک راست بریم سراغ اصل ماجرا ، به روتر یا سویچ متصل می شیم و بر اساس مراحل زیر جلو میریم :

1-روی یکی از interface های روتر یک IP استاتیک تعریف می کنیم و بعد inerface را up می کنیم :

1
2
3
Router(config)# interface ethernet0/0
Router(config-if)#ip address 1.1.1.1 255.0.0.0
Router(config-if)# no shutdown

2- خوب حالا یک address pool یا به قول ما ویندوزی ها Scope تعریف می کنیم:

1
Router(config)# ip dhcp pool mypool

3- خوب subnet mask رنج IP مورد نطرتون رو در ادامه وارد کنید ، روتر این رنج رو به درخواست هایی که بهش میرسه اختصاص میده :

1
Router(dhcp-config)# network 1.1.1.0 /8

4-خوب نام دامنه یا دامین را به DHCP سرور معرفی میکنیم :

1
Router(dhcp-config)#domain-name itpro.ir

5-خوب آدرس Primary و Secondary مربوط به DNS سرور رو هم به روتر معرفی میکنیم :

1
Router(dhcp-config)#dns-server 1.1.1.10 1.1.1.11

6-آدرس روتر یا Default Gateway رو در مرحله بعد اضافه می کنیم :

1
Router(dhcp-config)#default-router 1.1.1.1

7-خوب زمان Lease یا همون Lease Duration رو هم بهش اضافه می کنیم :

1
Router(dhcp-config)#lease 7

8-از حالت configuration mode خارج می شویم :

1
Router(dhcp-config)#exit

با این دستور مجددا به حالت global configuration وارد می شی و می تونی آدرس هایی رو که مد نظرت هست رو exclude کنی ، در این حالت وقتی DHCP سرور می خاد آدرس دهی کنه از این رنج برای کلاسنت ها استفاده نمی کنه و ما می تونیم به عنوان استاتیک IP برای سرور ها مون از این رنج استفاده کنیم .


9-خوب با دستور زیر 100 تا آدرس اول رنج IP رو exclude میکنیم .

1
Router(config)#ip dhcp excluded-address 1.1.1.0 1.1.1.100

خوب حالا تنظیمات کامل شده شما میتونی براحتی با استفاده از دستور ipconfig /renew آدرس IP کلاینت رو مجددا از DHCP درخواست کنید.

امیدوارم از این پست لذت برده باشید.

ادامه مطلب

کانفیگ کردن تلفن VOIP سیسکو مدلهای ۷۹۴۰ و ۷۹۶۰ با سیستم SIP

‫کانفیگ کردن تلفن VOIP سیسکو مدلهای ۷۹۴۰ و ۷۹۶۰ با سیستم SIP

پروتکل استاندارد مورد استفاده در VOIP پروتکل SIP و یا Session Initiation Protocol است.  اما شرکت سیسکو از سیستم مختص به خودش که Call Manager نامیده می‌شود و بر اساس پروتکل SCCP پیاده‌سازی شده، استفاده می‌کند؛ در نتیجه تلفن‌های سیسکو به صورت پیش فرض از پروتکل SIP استفاده نمی‌کنند.

با توجه به اینکه Asterisk از SIP پشتیبانی می‌کند نمی‌توان به‌صورت پیش‌فرض تلفن‌های سیسکو را در کنار Asterisk استفاده کرد و باید Firmware مخصوص VOIP را روی گوشی نصب کرد.

تشخیص ورژن و مشخصات Firmware:

برای تشخیص مشخصات گوشی، کلید Setting را فشار دهید، سپس در منوی باز شده گزینه status را انتخاب کنید.

چگونه تلفن voip سیسکو مدل 7940 و 7960 را با سیستم SIP هماهنگ کنیم؟

در پنجره جدید گزینه firmware versions را انتخاب کنید.

چگونه تلفن voip سیسکو مدل 7940 و 7960 را با سیستم SIP هماهنگ کنیم؟
در پنجره بعد، بخش App Load ID شماره‌ای مشابه P0030801SR02 نوشته شده‌است.

چگونه تلفن voip سیسکو مدل 7940 و 7960 را با سیستم SIP هماهنگ کنیم؟

سومین کاراکتر این شماره به سه شکل ۰، S یا M خواهد بود. این عدد به شکل زیر تفسیر می‌شود:

  • اگر سومین کاراکتر از این شماره ۰ باشد، به این معنی است که Firmware گوشی با پروتکل SCCP هماهنگ است.
  • اگر سومین کاراکتر از این شماره S باشد، به این معنی است که Firmware گوشی با پروتکل SIP هماهنگ است.
  • M سومین کاراکتر از این شماره به این معنی است که Firmware گوشی با پروتکل MSCP هماهنگ است.

چنانچه Firmware گوشی با پروتکل MSCP یا SCCP هماهنگ باشد، باید Firmware گوشی را جهت هماهنگ شدن با SIP عوض کرد.

تنظیم شبکه:

کلید Setting را فشار دهید، از منوی باز شده گزینه Network Configuration را انتخاب کنید.

چگونه تلفن voip سیسکو مدل 7940 و 7960 را با سیستم SIP هماهنگ کنیم؟

کلیدهای ‏‎**#‎ را به ترتیب فشار دهید تا قفل صفحه باز شود، به عکس قفل بالای صفحه توجه کنید چون شکل قفل بالای منوی تنظیمات نشان دهنده قفل بودن گوشی است (توجه داشته باشید که در نسخه‌های جدید تلفن سیسکو به جای این کلید میانبر باید از منو گزینه Unlock Config را انتخاب کنید). گزینه Erase Configuration -شماره ۳۳- را انتخاب کنید. و در صورتی که این گزینه فعال بود (گزینه به شکل Erase Configuration NO) بود کلید Yes و سپس کلید save را بفشارید.

چگونه تلفن voip سیسکو مدل 7940 و 7960 را با سیستم SIP هماهنگ کنیم؟

نکته ۱: در هر منو می‌توانید با زدن شماره منو گزینه را انتخاب کنید، به عنوان مثال با زدن عدد ۳۳ گزینه Erase Configuration انتخاب می‌شود.

نکته ۲: به صورت پیش فرض امکان ویرایش تنظیمات گوشی وجود ندارد و تنظیمات گوشی قفل است، در هر زمان با فشردن کلیدهای ‏‎**#‎ و یا در نسخه‌های جدید تلفن‌های سیسکو، انتخاب گزینه Unlock Config از منوی Setting، می‌توانید قفل گوشی را باز کنید.

پس از Unlock کردن تنظیمات، از منوی Setting گزینه Network Setup، سپس گزینه DHCP Enabled -شماره ۳۰- را انتخاب کنید،  کلید NO را بفشارید، پس از آن منو‌های ۶ و ۷ و ۸ و ۹ و ۱۴ را به شکل مناسب ویرایش کنید.

  • منوی ۶ آی‌پی آدرس گوشی
  • منوی ۷ ساب‌نت شبکه
  • منوی ۸ آی‌پی آدرس TFTP (آدرس آی‌پی tftp سروری که در بخش بعد راه‌اندازی می‌کنیم).
  • منوی ۹ گیت‌وی
  • منوی ۱۴ دی‌ان‌اس سرور

پس از وارد کردن هر مقدار کلید Validate را بفشارید و در انتها کلید Save  سپس از منو خارج شوید.

دانلود Firmware:

آخرین نسخه Firmware را از سایت سیسکو و یا سرچ در اینترنت دانلود کنید همچنین نسخه ۴۱٫۹-۴-۲-۱S را می‌توانید از اینجا دانلود کنید. سپس فایل را از حالت فشرده خارج کنید.

اگر نسخه ۴۱٫۹-۴-۲-۱S مناسب دستگاه شما نبود و به‌روز رسانی انجام نشد، فایل P0S3-08-6-00 را از اینجا دانلود و مجددا مراحل به‌روز رسانی را طی نمایید.

 

تنظیم Firmware:

در مسیر Firmware فایل‌های زیر را مشاهده خواهید کرد.

  • فایل OS79XX.TXT را باز کنید و محتوای آن را به نام آخرین ورژن Firmware تغییر دهید توجه داشته باشید حرف سوم حتما باید S باشد (به عنوان مثال P0S3-8-12-00).
  • فایل  SIPDefault.cnf را با محتوی زیر بسازید.
    • image_version: “P0S3-8-12-00”

راه اندازی سرویس TFTP:

روی یک سیستم ویندوز یا لینوکس TFTP سرور راه اندازی کنید.

سیستم عامل ویندوز:

  • برنامه tftpd32 را از این آدرس دانلود و نصب کنید.
  • کلید Setting را بفشارید، از بخش TFTP، بخش Base Directory، کلید Browse را فشار دهید و مسیر فایل Firmware را انتخاب کنید.
  • در انتها از بخش server interfaces آی‌پی اصلی سرور را انتخال کنید.

سیستم عامل گنو\لینوکس (اوبونتو):

  • برنامه tftpd-hpa با دستور زیر نصب کنید.
  • فایل تنظیمات tftpd را باز کنید و پارامتر TFTP_DIRECTORY را به مسیر فایل Firmware تغییر دهید.
  • سرویس tftpd-hpa را ری‌استارت کنید.

به‌روز رسانی Firmware:

منبغ تغذیه گوشی (فیش آداپتور و یا کابل شبکه چنانچه از POE استفاده می‌کنید) را قطع و مجددا وصل کنید، پس از راه‌اندازی مجدد گوشی Firmware جدید را از TFTP سرور دانلود می‌کند و Firmware گوشی به صورت خودکار به‌روز رسانی خواهد شد.

پس از به‌روز رسانی کلمه SIP در گوشه راست بالای صفحه دیده خواهد شد.

ادامه مطلب